Follow Along as I Stumble on the Path to Learning RoR

Error: C:/Dev/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require’: 193: %1 is not a valid Win32 application

I was receiving this error which was preventing me fom running my Rails server or any other commands locally:

C:/Dev/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require’: 193: %1 is not a valid Win32 application.   – C:/Dev/Ruby193/lib/ruby/1.9.1/i386-mingw32/digest/sha1.so (LoadError)

It started after I implemented a web hook, which conflicted with a local application.  I found out by after finding this post:

https://github.com/oneclick/rubyinstaller/issues/102

In the case of the poster, an app called FRAPS was causing the issue.  I don’t have that program, but after closing a bunch of apps from Windows’ Task Manager, it was working again.

Advertisements

Comments are closed.